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Part I

Creating the Duct Geometry and Mesh
1 Introduction for Part I

1.1 Overview
This tutorial covers the steps necessary to create a 3D model of laminar flow in a duct. The content is
based on Release 2410 (Version 19.06.008).

In the first part, a simple rectangular duct geometry is created in the STAR-CCM+ 3D-CAD Mod-
eler. The duct that will be created has a length Lx = 2.0 [m], a height Ly = 0.2 [m], and a depth
Lz = 0.3 [m]. A uniform orthogonal mesh is then created in the domain using a directed mesh. The
second part covers the steps required to set up and run a laminar flow simulation in the duct domain.

1.2 Objectives
This part is intended to demonstrate how to:

1. Open STAR-CCM+ using the Simcenter STAR-CCM+ Power on Demand License
2. Create a geometry using the STAR-CCM+ 3D-CAD Modeler
3. Convert the geometry created using the STAR-CCM+ 3D-CAD Modeler into a part for analysis
4. Create a directed mesh
5. Save the simulation

1.3 Saving in Stages
It is strongly recommended that you save your work under a different file name(using Save As) after
each section in this tutorial. After saving you can re-open the original simulation file and continue.
Saving periodically along the way allows you to get back to a previous working stage in case something
should not work as expected.

2 Creating the Duct Geometry
This section will outline the process of creating the duct geometry using the STAR-CCM+ 3D-CAD
Modeler. Note that the created duct geometry will only be half the height of the analyzed duct because
symmetry will be assume about the x-z plane at y = 0.

2.1 Opening the STAR-CCM+ Software
This section will show you how to open a new simulation using the STAR-CCM+ software, including
how to set your license, how to input your key, and how to save a file.

1. Launch STAR-CCM+.
2. At the top of the window, in the Toolbar, click on the Create a File icon.
3. Ensure the file type is set to Simulation and set the License to Simcenter STAR-CCM+ Power on

Demand.
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4. If it is your first time using STAR-CCM+, enter your POD key for the STAR-CCM+ license you
have been provided. If this is not your first time using STAR-CCM+, the key should already be
entered.
Once this is complete, click OK. This process is highlighted in Figure 1. More information on
using Power on Demand Licensing can be found on Page 119 of the User Guide.

Figure 1: STAR-CCM+ license selection screen.

5. When you open the STAR-CCM+ software, a layout similar to Figure 2 should appear. This layout
will be referenced throughout the tutorial. More information on the STAR-CCM+ menu layout
can be found on Page 186 of the User Guide.
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Figure 2: STAR-CCM+ layout.

6. At the top of the window, click on File → Save As. . .
Select an appropriate location for the Simulation file and set the file name to duct. Click Save.

2.2 Creating the 3D-CAD Model
This section will summarize the process of creating a model using the STAR-CCM+ 3D-CAD Modeler,
including how to prepare grid lines for sketching, how to create and dimension a sketch, and how to use
the extrude feature.

1. In the Explorer Pane, expand the Geometry node. Right click on 3D-CAD Models and click New,
as shown in Figure 3. The STAR-CCM+ 3D-CAD Modeler will open in the Graphics Window.
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Figure 3: Opening the STAR-CCM+ 3D-CAD Modeler.

2. Right click on the YZ node under Features and select Create a Sketch. Grid lines will appear in
the Graphics Window.
You can zoom in or out by scrolling the mouse. To rotate the grid, left click in the Graphics
Window and drag the mouse. To pan, right click in the Graphics Window and drag the mouse.
These mouse commands will work for any scene in the Graphics Window.

3. Under the Display Options click on the View Normal to Sketch Plane icon. This will align the sketch
plane normal to the screen. This icon is shown in Figure 4.

Figure 4: View Normal to Sketch Plane icon.
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4. Click on the Set Sketch Grid Spacing icon under the Display Options section. This icon is shown in
Figure 5.

Figure 5: Set Sketch Grid Spacing icon.

5. The Grid Spacing dialog box will open. Change the grid spacing to 0.05 [m] and change the
number of fine grid deviations to 1.0, as shown in Figure 6. Once this is complete, click OK.

Figure 6: Grid Spacing menu.

You may need to zoom out by scrolling to decrease the size of the grid at this point. You may also
need to right click to pan either horizontally or vertically in the Graphics Window.

6. Click on the Rectangle icon in the Create Sketch Entities section, shown in Figure 7.
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Figure 7: Rectangle sketch tool.

7. Create a rectangle spanning 4 squares horizontally and 6 squares vertically by clicking on the
origin of the sketch plane and again on the opposite corner of the rectangle. The sketch should
look similar to Figure 8.

Figure 8: Initial duct cross-section sketch.

The sketch will automatically attempt to lock onto grid lines.
8. Right click on one of the horizontal lines and select the Apply Length Dimension under the

Dimensions section. The Dimension Window will open. If necessary, change the length of the
line to 0.2 [m] and click OK.

9. Right click on one of the vertical lines and select the Apply Length Dimension under the Dimensions
section. The Dimension Window will open. If necessary, change the length of the line to 0.3 [m]
and click OK. The completed sketch with dimensions is shown in the following Figure 9.
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Figure 9: Completed duct cross-section sketch.

10. Once you have defined the dimensions of your sketch, click on the OK button in the Explorer Pane
to create the sketch.

11. Right click on Sketch 1 and select Rename. Rename the sketch to Duct Cross-Section Sketch.
Alternatively, you can use the F2 hotkey to rename a node in the Explorer Pane.

12. Right click on Duct Cross-Section Sketch and select the Extrude option. This process and the
renaming process is shown in Figure 10.

Figure 10: Renaming and extrusion features in tree.

13. The Extrusion Window will open in the Explorer Pane. Change the distance to 2.0 [m] and click
OK. This can be seen in Figure 11.
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Figure 11: Extrusion of cross-section sketch in explorer window.

14. Right click on the Extrude 1 feature and select Rename. Rename the extrusion to Duct.
Open the Duct → Body Groups node. Right click on Body 1, select Rename, and rename the
feature to Duct Body.

15. In the Display Window, right-click each individual face of the model and rename it using the
following naming convention shown in Table 1. Figure 12 depicts renaming the negative x-face to
”Inlet”:

Table 1: Naming Conventions for Duct Faces
Face: Plane: Name:
Negative x-Face x = 0 Inlet
Positive x-Face x = Lx Outlet
Negative y-Face y = 0 Symmetry Plane
Positive y-Face y = Ly Top Wall
Negative z-Face z = 0 Left Wall
Positive z-Face z = Lz Right Wall
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Figure 12: Renaming for faces in the 3D-CAD modeler.

16. Click on the Close 3D-CAD button in the Explorer Pane. The CAD model is now complete.

2.3 Creating a Part from a 3D-CAD Model
Now that the 3D-CAD model is complete, it must be converted to a geometry part for meshing and
analysis. This section summarizes the process of creating a part from a 3D-CAD Model in STAR-CCM+.
Alternatively, one could have created a 3D-CAD model in another software, imported it, and then it
may be converted into a part using the same process.

1. Click on Geometry → 3D-CAD Models and rename 3D-CAD Model 1 to Duct.
2. To create a part from the 3D-CAD Model in STAR-CCM+, right click on Geometry → 3D-CAD

Models → Duct. Select the New Geometry Part option,as shown in Figure 13.

Figure 13: Process of creating a part from a 3D-CAD model.

3. The Part Creation Options dialog box will open. For this tutorial, the default settings will be
what is used, so click OK. This process is shown in the following Figure 14:
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Figure 14: Part creation options dialog box.

4. To view your geometry in the Display Window, right click on Scenes and select New Scene → Geometry.
This is shown in the following Figure 15.
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Figure 15: Extrusion of cross-section sketch in explorer window.

5. The duct should now be available in the Display Window and should look similar to Figure 16.

Figure 16: View of duct body in geometry scene.

6. Prior to setting up the mesh for the geometry, the geometry part must be converted into regions.
Regions are various surfaces on the part where you can set boundary conditions and define the
behaviour of the surfaces of a part. To do this, right click on Geometry → Parts → Duct Body and
select Assign Parts to Regions. . .
This process is shown in Figure 17.
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Figure 17: Process of assigning parts to regions.

7. The Assign Parts to Regions dialog will open. Select the Duct Body as the part to assign to
regions. Change the pull down menus as required to read the following:

• Create a Region for Each Part
• Create a Boundary for Each Part Surface
• Create Boundary-mode Interfaces From Contacts

The selected options on the pull down menus should look like Figure 18. Once this is completed
click Apply and Close.
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Figure 18: Assign Parts to Regions menu selections.

8. To ensure you have correctly assigned parts to regions correctly, you can expand the Regions → Duct
Body → Boundaries node. Each face named when creating the 3D-CAD model should have been
converted into a separate boundary as seen in Figure 19:
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Figure 19: Boundaries created when assigning parts to regions.

9. The part geometry has been created and set up for meshing. Ensure the simulation is saved prior
to starting the meshing section by clicking File → Save, and title the simulation duct.sim.

3 Meshing
This section outlines the process of creating a mesh for a given part. The purpose of creating a mesh
is to divide the geometry into volumes (or areas for a 2D mesh) used in the discretisation process.
This section will also summarize the procedure of exporting a mesh for use in later simulations. The
saved file can be used in the subsequent tutorial: STAR-CCM+ Introduction Tutorial Part 2: Laminar
Flow in a Rectangular Duct. The meshing process used is just one type of mesh generation available in
STAR-CCM+.

3.1 Creating a Directed Mesh
The type of mesh that will be used in this analysis will be a directed mesh. The key features of a
directed mesh are the source surface and the target surface. A patch mesh is created on the source
surface and is extended through the use of a volume distribution to the target surface.
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1. To begin creating the mesh for the simulation, right click on Geometry → Operations and select
New → Mesh → Directed Mesh, as shown in Figure 20.

Figure 20: Process of selecting the directed mesh option.

2. The Create Directed Mesh Operations menu will open on screen. Click on Duct Body to select the
body you wish to create the mesh for and click OK. A new Directed Mesh node will appear under
Operations in the Explorer Pane.

3. Right click on Geometry → Operations → Directed Mesh and select Edit. . .
This process is shown in Figure 21. The Directed Mesh window will open in the Explorer Pane.

Figure 21: Process of opening the mesh editor.

4. Select the Source Surfaces node and in the Properties Window, open the Custom Editor and select
the Inlet as the source surface. The button to open the Custom Editor is shown in Figure 22.
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Figure 22: Button to open the Custom Editor.

5. Select the Target Surfaces node and in the Properties Window, open the Custom Editor and select
the Outlet as the target surface.
The Directed Mesh will begin on the Source Surface and travel to the Target Surface, which is why
these surfaces must be defined prior to creating the mesh.

6. Right click on the Source Meshes node and select New Source Mesh → Patch Mesh.
The Part Collection For This Source Mesh window will open in screen. Select the Duct Body as the
part you wish to create the source mesh for and click OK.

7. The Patch Mesh Editor will open, which is where the mesh is created on the source surface. Click
on the Auto-Populate Feature Edges with Patch Curves icon under the Create/Edit Patch Entities
section. This icon is shown in Figure 23. Once this is done correctly, the edges of the source
surface will change colour from yellow to green. Your patch topology should begin by looking like
Figure 24a and end looking like Figure 24b.

Figure 23: Auto-Populate Feature Edges with Patch Curves icon.

(a) Initial patch topology. (b) Final patch topology.

Figure 24: Patch topology on source surface.

The Auto-Populate Feature Edges with Patch Curves feature will automatically create one large
patch mesh around the perimeter of the source surface. This is the desired patch mesh for the
simulation, so the patch mesh creation is complete.
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8. At the top of the Explorer Pane, change to mode from Patch Topology to Patch Mesh. This is
where the number of nodes in each direction on the source surface are specified. Click on one of
the horizontal edges. The Mesh Properties section in the Explorer Pane will become available once
done correctly. Change the number of divisions to 15 and click Apply, as shown in Figure 25.

Figure 25: Process of specifying the horizontal mesh divisions.

9. Click on one of the vertical edges. The Mesh Properties section in the Explorer Pane will become
available once done correctly. Change the number of divisions to 10 and click Apply, as shown in
Figure 26.

Figure 26: Process of specifying the vertical mesh divisions.

10. Once both actions are completed correctly, the mesh on the source surface should appear in the
Display Window. When the mesh looks similar to the mesh in Figure 27, click on Close to close
the surface mesh.

Figure 27: Patch mesh of source surface.

11. Right click on Mesh Distributions and select New Volume Distribution, as shown in Figure 28. The
Parts for Creating a New Mesh Distribution menu will open on screen. Select the Duct Body as
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the body to create the volume mesh for and click OK. A new Volume Distribution node will be
added under Mesh Distributions. Ignore the Default Distribution node, which appears in the latest
software version.

Figure 28: Creating the volume distribution node.

The purpose of the volume distribution is to set the number of divisions of the patch mesh from
the source surface through the body to the target surface.

12. Select Mesh Distributions → Volume Distribution → Default Controls → Number of Layers and in
the Properties Window, change the Number of Layers to 40 and hit Enter. This process is shown
in Figure 29.

Figure 29: Process defining the volume distribution.
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13. The directed mesh is now complete, so click on Close Directed Mesh. This will cause STAR-CCM+
to return to the Geometry Scene.

14. To update the directed mesh, right click on Geometry → Operations → Directed Mesh and select
Execute. The small caution icon beside Directed Mesh node will vanish once completed .

15. To view the directed mesh, right click on Scenes and select New Scene → Mesh
A new scene should open in the Graphics Window which shows the Duct Body and the directed
mesh, similar to Figure 30.

Figure 30: View of duct body in mesh scene.

16. Save the simulation by clicking File → Save.

Part II

Laminar Flow Simulation
4 Introduction for Part II

4.1 Overview
The starting point for this part is the simulation file from Part I. The main objective of this part is to
familiarize a new user with the StarCCM+ workflow and interface.

4.2 Geometry Nomenclature
The rectangular duct domain created in Part I is shown schematically in Figure 31.
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Figure 31: Rectangular Duct Geometry

The duct has length Lx, height Ly, and depth Lz. The flow is assumed to be symmetric about an
x-z plane that bisects the duct, and therefore only half of the full duct is modelled. One corner of the
duct is defined to lie at the origin, (0,0,0). All faces of the domain were defined during the modelling
process and are named as follows: the plane described by x = 0 is denoted as Inlet, x = Lx as Outlet,
y = 0 as Symmetry Plane, y = Ly as Top Wall, z = 0 as Right Wall, and z = Lz as Left Wall. Pertinent
geometric parameters are given in Table 2.

4.3 Problem Definition
In this tutorial, an isothermal, incompressible, constant property flow of water through a rectangular
duct is modelled. There is no heat transfer model engaged; alternative approaches such as using an
isothermal flow model or adding heat transfer could be explored as extensions to this tutorial.

The flow is modelled using a rectilinear uniform grid for half the domain, using symmetry in the y
direction. All physical parameters required for the simulation are given in Table 2 below.
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Table 2: Geometric and Physical Parameters

Parameter Symbol Value Units Comments
mass flow rate ṁ 1.981×10−2 kg/s half of the total mass flow of 3.962×10−2 kg/s
density ρ 997.0 kg/m3

dynamic viscosity µ 8.899×10−4 kg/m·s
duct length Lx 2 m
duct height (half) Ly 0.2 m half of the total duct height of 0.4 m
duct depth Lz 0.3 m
hydraulic diameter Dh 0.34286 m used to calculate the Reynolds number
Reynolds Number ReDh

127.2 – indicates a laminar flow regime

4.4 Objectives
This part is intended to demonstrate how to:

1. Select physics models
2. Review and apply initial conditions and understand their importance in solution convergence
3. Specify boundary conditions
4. Set stopping criteria
5. Run a simulation
6. Perform some post-processing of results within the STAR-CCM+ environment
7. Export solution data for further post-processing

5 Setting Up the Simulation
STAR-CCM+ solves physics problems using a computational mesh. To provide this mesh, you can either
(a) create a geometric model within the STAR-CCM+ environment and then use that model to create
the mesh within STAR-CCM+, or (b) import an existing mesh. It is strongly recommended to use
method (a), which corresponds to continuing with the duct.sim file that you saved from Part I.

It is recommended that you save the simulation periodically during the set-up process. Use Save As
to save progress under other file names to allow getting back to a previous stage should something not
work as expected.

5.1 Starting from the Previous Simulation
1. Launch STAR-CCM+.
2. Open the previously created duct.sim file.
3. Save the simulation as duct-lam.sim in the file directory you created in Part I. Close the duct.sim

simulation tab.
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5.2 Selecting the Physics Models
A physics continuum defines a set of physics models and their associated material. A physics model
is associated with one or more regions. With a mesh defined, a region now exists to which a physics
model can be applied.

1. Expand the Continua node and right-click on Physics 1 (this is the physics continuum automatically
created and assigned to the Duct Body region).

Figure 32: Select Model menu item in Continua

2. Click on Select Models.... The Physics Model Selection dialog should appear:

Figure 33: Physics Model Selection dialog box

3. Select the following physics models, in order:
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Table 3: Summary of physics models to select

Group Box Model
Enabled Models Three Dimensional (pre-selected)
Material Liquid
Flow Segregated Flow

Gradients (selected automatically with above)
Equation of State Constant Density
Time Steady
Viscous Regime Laminar

Then press Close to exit the dialog box, as no optional models are required for this simulation.
Notice the following:

• Since Auto-select recommended models is engaged, the Physics Model Selection dia-
log guides you through the model selection process by prompting you for required models
based on previous selections, and selecting certain default models automatically as you make
choices. For example, when a continuum has contains a liquid or a gas, it also needs a flow
model. Once it has a flow model, it needs a viscous model. If turbulence is activated in a
fluid continuum, it will need a turbulence model.

• Water is the default substance defined for a liquid continuum. This can be seen by expanding
Continua → Physics 1 → Models → Liquid → H20.

• To reverse part or all of the model selection processes, simply clear the checkboxes of the
models you want to deactivate. Active models that are grayed out require other models to
be deactivated first.

• The color of the Physics 1 node has turned from gray to blue, indicating that required models
have been activated.

4. Open the Continua → Physics 1 → Reference Values node and select Reference Pressure. Ensure
that the Value property is set to to 101325.0 Pa.

• Flow simulations require the specification of a reference pressure. The reference pressure is
simply a device that is used to reduce the numerical roundoff error in the numerical calcula-
tions involving pressure. This is necessary since the differences in pressure are important, and
these differences can be small relative to the absolute value of the pressure. Other reference
values may be required in more complex flow simulations.

• A short explanation is given in the Properties Window when a Property is selected. As well,
(Help) or F1 can be used to find the entry in the STAR-CCM+ User Manual to learn more

about most objects.
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Figure 34: Specifying the reference pressure

5.3 Setting the Fluid Properties and Initial Conditions
1. Expand the Continua → Physics 1 → Models → Liquid → H20 → Material Properties Density node

and and select the Constant Node.
2. Set the Value property to that given for density in Table 2 (enter 997.0).

Figure 35: Entering the fluid density

3. Similarly, set the Value property for Dynamic Viscosity to that given in Table 2 (enter 8.889E-04).
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4. Expand the Physics 1 → Initial Conditions node and select the Pressure node. Verify that the
Method is Constant and the Value is 0.0 [Pa]. This defines the initial pressure field of the fluid at
the start of the simulation.

5. Similarly, select the Velocity node and verify that the Method is constant and that the value
is [0.0, 0.0,0.0] [m/s]. This defines the initial velocity field of the fluid as stationary in the
Laboratory coordinate system, which is the default reference frame of any continuum.

Figure 36: Specifying the initial conditions

5.4 Specify the Boundary Conditions
Boundary conditions are applied under the Regions → Boundaries node. In Part I, you Assigned Parts
to Regions when creating the mesh. This step created Boundaries from previously defined part surfaces.
The following boundary conditions are applied to those boundaries:

Table 4: List of boundary conditions

Boundary Condition
Inlet Mass Flow Inlet
Left Wall Wall
Outlet Pressure Outlet
Right Wall Wall
Symmetry Plane Symmetry Plane
Top Wall Wall
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1. Check that the boundaries are properly defined: with Mesh Scene 1 open in the Graphics Window,
open the Regions → Duct Body → Boundaries node and click on each boundary in sequence. The
selected boundary should be highlighted in pink in the graphics window. As well, ensure all
boundary conditions are set in the default Laboratory (or Lab) coordinate system.

2. Set the Inlet boundary condition:
2.1. Select the Inlet node and set the Type property to Mass Flow Inlet.

Figure 37: Inlet boundary condition selection

Note here that the Part Surfaces property contains [Duct Body.Inlet]. The Part Surfaces
property dictates the geometric entities (in this case a region) associated with this Boundary.

2.2. Expand the Inlet → Physics Conditions node and select Flow Direction Specification. The
Method should be set to Boundary-Normal, but note the other options available.
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Figure 38: Mass flow direction specification

2.3. Select the Mass Flow Option node and verify that Specification Option is set to Mass Flow
Rate. The alternative option is to define a mass flux at the boundary.

Figure 39: Mass flow specification option

2.4. Expand the Inlet → Physics Values node and select Mass Flow Rate. Set the Value property
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to that given in Table 2 (enter 1.981E-02).
3. Set the Outlet boundary condition:

3.1. Select the Outlet node and set the Type property to Pressure Outlet.
3.2. Expand the Outlet → Physics Conditions node and select Backflow Specification Option.

Change the Pressure property from Environmental to Static. The Environmental condition
subtracts the dynamic head at the pressure boundary, while the Static condition maintains
the pressure at the user-defined pressure.

Figure 40: Backflow specification

Leave the other conditions as default, noting:
• The Direction property controls the flow direction at the boundary, with options of:

– Boundary Normal - as the name suggests, the flow is normal to the boundary.
– Extrapolated - extrapolates the flow from the interior of the domain.
– Components or Angles - these options specify the flow directly in 3D space through

either a unit vector or Euler angles.
• The Scalars property controls how the scalar quantities (e.g., temperature) are defined

at the boundary, with options of:
– Specified - applies the scalar conditions that you specify if the flow reverses at the

boundary, otherwise, extrapolates scalar conditions from the domain.
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– Extrapolated - extrapolates the conditions from the domain regardless of the flow
direction.

3.3. In the same node, select Pressure Outlet Option. Set the Option to Average Pressure.
3.4. Expand the Outlet → Physics Values node and select Average Pressure. Verify that the Value

property is 0.0 [Pa]. Recall that this is a gauge pressure to the Reference Pressure set in the
Physics 1 continua. Therefore, the absolute average pressure at the outlet is 101325.0 [Pa].

3.5. Next, select the Average Pressure Adjuster node and change the Blending Factor property to
0.05.

Figure 41: Average pressure adjuster

4. Set the Symmetry Plane boundary condition: select the Symmetry Plane node and set the Type
property to Symmetry Plane.

5. Set the Wall boundary conditions:
5.1. Expand the Left Wall node and verify that the Type property is set to wall.
5.2. Expand the Left Wall → Physics Conditions node and select Shear Stress Specification. Ensure

that the Method property is set to No-Slip.
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Figure 42: Shear stress specification

5.3. Perform the last two steps for the both the Right Wall and Top Wall boundaries.

5.5 Set the Stopping Criteria
Stopping criteria for this simulation will consist of a maximum number of iterations and a minimum
limit for the conservation equation residuals. Note that the criteria that are set below are nominal and
work on most current desktop computers. There have been situations where the residual level is not
met on some PC hardware. If this is the case when you run the simulation, you may need to adjust the
criterion value.

1. Expand the Stopping Criteria node and note that the two default criteria (Maximum Steps and
Stop File) for steady simulations are present. Automatically generated stopping criteria cannot
be deleted, but the Enabled Property can be activated or deactivated.

2. Select the Stop File node and uncheck the Enabled property to disable the criterion.
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Figure 43: Stop file disable step

3. Select the Maximum Steps node and change the Maximum Steps property to 6000. Leave the
Logical Rule property as Or.

Figure 44: Maximum steps setting

4. Create the stopping criterion for the continuity equation residual:
4.1. Right-click the Stopping Criteria node and select New Monitor Criterion.
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Figure 45: New monitor criterion specification

4.2. In the Select Monitor dialog that appears, select the Continuity residual. Click OK to close
the dialog box.

Figure 46: Select monitor dialog box: Continuity

4.3. Select the newly created Stopping Criteria > Continuity Criterion and change the Logical Rule
property to And.

Figure 47: Continuity criterion logical rule
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4.4. Select the Minimum Limit and set the Minimum Value to 1.0E-06.

Figure 48: Continuity criterion minimum limit

5. Create stopping criteria for the X-, Y-, and Z-momentum residuals in a similar fashion, with the
Logical Rule set to And and the Minimum Value set to 1.0E-6.

6 Running the Simulation
Note that if there are any monitoring values or plots that you wish to observe during the simulation,
they should be set up before the simulation is run. For this case, post-processing will be demonstrated
after the run.

1. In the toolbar, click the (Initialize Solution) or use the Solution → Initialize menu item to
manually initialize the solution. If your had existing visualizations, you could use them to examine
the initial conditions at this point.

2. Run the simulation by clicking (Run), pressing <Ctrl><R>, or use the Solution → Run menu
item. You may also use the (Step) to step through the iterations one by one.

3. A residual plot will automatically be created and you may watch it as the solution progresses to
convergence.

4. After the solution has converged, try clearing it using the Solution → Clear Solution... menu item
(keep the Fields box checked to clear solution fields). Then run the solution again, stopping it
partway through with the (Stop) button on the toolbar. Press (Run) again and notice that
the solution continues iterating from where it was stopped.
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7 Post-Processing the Simulation in STAR-CCM+
If existing simulation surfaces are not sufficient to use in plotting, visualizing, or reporting data, Derived
Parts are created. Here, we will create a line probe, which is used to sample the velocity field at cells
along the Outlet boundary. A visual for the velocity field along the Symmetry Plane will also be created.

1. Create the line probe derived part:
1.1. Open the Geometry Scene 1. We must change the view to properly visualize the line probe

– we will use this opportunity to find out how to achieve specific views within the Graphics
Window and save them for later use. Select the (Save-Restore-Select Views) button in the
toolbar, and navigate to Views → +X +Y +Z → Up +Y.

Figure 49: Geometry scene view setting

1.2. Save the view by using the Store Current View option under . This view can now be
accessed at any time through → Restore View → View 1.

Figure 50: Restore view menu

1.3. Right-click on the Derived Parts node and select New Part → Probe → Line...
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Figure 51: New probe line menu

This should open an Edit window automatically. If it does not, with the mesh or geometry
scene open in the Graphics Window, right-click the Outlet Velocity node and select Edit Part
in Current Scene.

1.4. Click the Select... button to select Input Parts for the line probe.

Figure 52: Select button for probe line creation

This action will open the Select Objects dialog box.
1.5. De-select the Duct Body region by clicking twice on the side of the item-tree. Then, select

just the Outlet boundary.

Figure 53: Select outlet boundary
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1.6. Enter (2.0, 0.0, 0.0) m and (2.0, 0.0, 0.3) m respectively for Point 1 and Point 2. Set
the Resolution to 14 – this is the number of points the line probe will sample. Since there
are only 14 cells in the z-direction, having greater than 14 points is unnecessary. Set the
Display to the No Displayer radio button. The line you are describing should be visible in the
Graphics Window as a barbell.

Figure 54: Line probe options

1.7. Click Create at the bottom of the Edit window, and then click Close.
1.8. Rename the newly created Line Probe derived part by right-clicking and selecting Rename,

or selecting it and pressing <F2>. Rename the part to ‘Outlet Line’.

2. Create an XY Plot to visualize the velocity field at the outlet:
2.1. Right-click the Plots node and select New Plot → XY Plot The newly created XY Plot 1 node

should open and expand automatically when it is created, and a new window should appear
in the Graphics Window titled ‘XY Plot 1’.

2.2. With the XY Plot 1 node selected, open the Parts property selection by clicking the [...]
(Property Customizer) button.
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Figure 55: Part selection for XY plot

The XY Plot 1 - Parts dialog box will open.
2.3. Select the Outlet Line part and click Close to exit the dialog box.

Figure 56: Outlet Line selection

2.4. Expand the XY Plot 1 → X Type node and select the Vector Quantity node. Change the Value
property to [0,0,1] m (this is the direction of the line probe).
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Figure 57: Vector quantity specification

2.5. Select the Y Types → Y Type 1 node and engage the Smooth Values option. This activates
solution interpolation, and is an extremely important step to generally include when using
XY Plots.

Figure 58: Select smooth values for plot

2.6. Expand the Y Types → Y Type 1 node and select the Scalar Function node. In the Field
Function property, click [...] to open the Scalar Function - Field Function dialog box. This
provides all of the scalar field functions available to be plotted.

University of Manitoba R2.00 2025-01-08



STAR-CCM+ Introduction Tutorial: Laminar Flow in a Rectangular Duct Page 41 of 45

Figure 59: Scalar field function selection for plot

2.7. In the Scalar Function - Field Function dialog box, select Velocity → Lab Reference Frame → Lab-
oratory → i. This selection is made easier by searching for ’Velocity’ in the search bar.

Figure 60: Vector direction specification

2.8. Expand the Y Type 1 → Outlet Line node and select Line Style. Change the Style property
from None to Solid. Similarly, select Symbol Style and change the Style property from Empty
Circle to None.
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Figure 61: Line style and symbol style specifications

2.9. Select the Axes → Bottom Axis node. Change the Minimum property to 0.0 and the Maximum
property to 0.3, to reflect the z-extent of the domain.

2.10. Expand the Bottom Axis node and select the Title node. Set the Title property to ’Z [m]’.
2.11. Select the Axes → Bottom Axis → Major Labels node and change the Spacing to 0.05.
2.12. Expand the Axes → Left Axis node. Change the Title property to ’U Velocity [m/s]’ in the

Title node.
2.13. Open the Left Axis → Major Labels node and change the Spacing property to 5.0E-5. Also

change the Notation property to scientific.
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Figure 62: Major labels specification

The plot should appear as below:

Figure 63: U-velocity profile at the outlet.

2.14. Export the U-velocity profile data as a *.csv for post-processing in another program (e.g.
Gnuplot): right click anywhere in the XY Plot 1 scene, and select Export. . .. Enter an
appropriate name and location in the Save dialog.
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3. Create a vector scene of the velocity field on the symmetry plane:
3.1. Right-click on Scenes and select New Scene → Vector. A vector scene should appear in the

Graphics Window.
3.2. Expand the newly created Vector Scene 1 → Vector 1 node and select Parts using [...].
3.3. In the Parts dialog box, select the Symmetry Plane region and press OK.
3.4. Select the Vector 1 → Vector Field node and change the Function property to Velocity.
3.5. Select the Vector 1 → Color Bar node and change the Color Map to purple-red basic (large

difference) to better visualize the velocity.
3.6. Select the Vector 1 → Glyph > Relative Length node and change the Glyph Length (%) to 2.5

to better visualize the velocity.
The scene should appear as below:

Figure 64: Velocity field at the symmetry plane.

3.7. Save the vector scene as an image: right-click anywhere in the Vector Scene 1, and select
Hardcopy. . . Enter an appropriate name and location in the Save dialog that appears. Note
that a variety of image file types are available, and the resolution of the image may be
adjusted.

4. Clear the solution, then initialize and re-run or step through it with Outlet Velocity Profile or
Vector Scene 1 open – watch the velocity field change as the solution converges.
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8 Further Exploration
In order to gain more experience using STAR-CCM+, you can complete the following additional tasks.

1. Restart the flow calculation and converge to a tighter tolerance.
1.1. Load the duct-lam.sim file.
1.2. Export the outlet velocity profile for post-processing in an external software by right-clicking

on XY Plot 1 and selecting Export... and then save as duct-lam-1E-06.csv.
1.3. Open the stopping criteria and change:

• Maximum iterations to 500
• Minimum limit for all residuals to 1.0E-8.

1.4. Create a new dataset by expanding the Tools node and right-clicking on Tables, then selecting
New Table... → File Table and open the duct-lam-1E-06.csv file.

1.5. Open the XY Plot 1 node and right-click on Data Series, then select Add Data. In the Add
Data Providers to Plot dialog box, select the duct-lam-1E-06 dataset and press OK. Open XY
Plot 1 in the Graphics Window to view the results.

2. Add the energy equation calculation and thermal boundary conditions.
2.1. Load the duct-lam.sim file.
2.2. Right-click on the Continua → Physics 1 node and press Select Models.... Select the Segregated

Fluid Temperature model from the list of Optional Models.
2.3. Open the Continua → Physics 1 > Models → Liquid → H20 → Material Properties and note

that Specific Heat and Thermal Conductivity were added. Leave the default values.
2.4. Also notice that Static Temperature has been added to the Initial Conditions and that Maximum

and Minimum Allowable Temperature have been added to the Reference Values. Leave the
default values.

2.5. Expand the Inlet boundary node and then open the Physics Values → Total Temperature node.
Verify the Value property is set to 300 K.

2.6. For each of the Left, Top, and Right Wall boundaries, change the Physics Values → Thermal
Specification from Adiabatic to Heat Flux. Set the Physics Values → Heat Flux to a constant
value of 666.67 [W/m2] for each wall.

2.7. Add a new Stopping Criterion for the energy conservation equation as done for the other
conservation equations.

2.8. Clear and re-run the simulation.
2.9. Create a contour plot of the temperature field at the outlet face: Create a new Scalar Scene.

Set the Parts for both the Outline 1 and Scalar 1 displayers to [Duct Body: Outlet]. Set the
Scalar Field to the Temperature field function.

2.10. Create a new plot of the temperature profile at the outlet using the existing line probe
(created for the velocity profile).

2.11. Create a new line probe that goes down the center of the duct, and then create a chart that
plots temperature along this line.
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