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1 Introduction

1.1 Overview
This tutorial covers the steps necessary to create a simple rectangular duct geometry and mesh using
STAR-CCM+. The geometry of the domain is created in the STAR-CCM+ 3D-CAD Modeler. The duct
that will be created has a length Lx = 2.0 [m], a height Ly = 0.2 [m], and a depth Lz = 0.3 [m]. A
uniform orthogonal mesh is then created in the domain using a directed mesh. The mesh file is the
saved and used in the second part of this tutorial: STAR-CCM+ Introduction Tutorial Part 2: Laminar
Flow in a Rectangular Duct.

1.2 Objectives
This tutorial will demonstrate how to:

1. Open STAR-CCM+ using the Simcenter STAR-CCM+ Power on Demand License
2. Create a geometry using the STAR-CCM+ 3D-CAD Modeler
3. Convert the geometry created using the STAR-CCM+ 3D-CAD Modeler into a part for analysis
4. Create and understand the concepts of a directed mesh
5. Export the created mesh for use in future simulations

1.3 Saving in Stages
It is strongly recommended that you save your work under a different file name(using Save As) after
each section in this tutorial. After saving you can re-open the original simulation file and continue.
Saving periodically along the way allows you to get back to a previous working stage in case something
should not work as expected.

2 Creating the Duct Geometry
This section will outline the process of creating the duct geometry using the STAR-CCM+ 3D-CAD
Modeler. Note that the created duct geometry will only be half the height of the analyzed duct because
symmetry will be assume about the x-z plane at y = 0.

2.1 Opening the STAR-CCM+ Software
This section will show you how to open a new simulation using the STAR-CCM+ software, including
how to set your license, how to input your key, and how to save a file.

1. Launch STAR-CCM+.
2. At the top of the window, in the Toolbar, click on the Create a File icon.
3. Ensure the file type is set to Simulation and set the License to Simcenter STAR-CCM+ Power on

Demand.
4. If it is your first time using STAR-CCM+, enter your POD key for the STAR-CCM+ license you

have been provided. If this is not your first time using STAR-CCM+, the key should already be
entered.
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Once this is complete, click OK. This process is highlighted in Figure 1. More information on
using STAR-CCM+’s Power on Demand Licensing can be found on Page 87 of the User Guide.

Figure 1: STAR-CCM+ license selection screen.

5. When you open the STAR-CCM+ software, a layout similar to Figure 2 should appear. This layout
will be referenced throughout the tutorial. More information on the STAR-CCM+ menu layout
can be found on Page 9067 of the User Guide.
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Figure 2: STAR-CCM+ layout.

6. At the top of the window, click on File → Save As. . .
Select an appropriate location for the Simulation file and set the file name to duct. Click Save.

2.2 Creating the 3D-CAD Model
This section will summarize the process of creating a model using the STAR-CCM+ 3D-CAD Modeler,
including how to prepare grid lines for sketching, how to create and dimension a sketch, and how to use
the extrude feature.

1. In the Explorer Pane, expand the Geometry node. Right click on 3D-CAD Models and click New,
as shown in Figure 3. The STAR-CCM+ 3D-CAD Modeler will open in the Graphics Window.
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Figure 3: Opening the STAR-CCM+ 3D-CAD Modeler.

2. Right click on the YZ node under Features and select Create a Sketch. Grid lines will appear in
the Graphics Window.
You can zoom in or out by scrolling the mouse. To rotate the grid, left click in the Graphics
Window and drag the mouse. To pan, right click in the Graphics Window and drag the mouse.
These mouse commands will work for any scene in the Graphics Window.

3. Under the Display Options click on the View Normal to Sketch Plane icon. This will align the sketch
plane normal to the screen. This icon is shown in Figure 4.

Figure 4: View Normal to Sketch Plane icon.
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4. Click on the Set Sketch Grid Spacing icon under the Display Options section. This icon is shown in
Figure 5.

Figure 5: Set Sketch Grid Spacing icon.

5. The Grid Spacing dialog box will open. Change the grid spacing to 0.05 [m] and change the
number of fine grid deviations to 1.0, as shown in Figure 6. Once this is complete, click OK.

Figure 6: Grid Spacing menu.

You may need to zoom out by scrolling to decrease the size of the grid at this point. You may also
need to right click to pan either horizontally or vertically in the Graphics Window.

6. Click on the Rectangle icon in the Create Sketch Entities section, shown in Figure 7.
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Figure 7: Rectangle sketch tool.

7. Create a rectangle spanning 4 squares horizontally and 6 squares vertically by clicking on the
origin of the sketch plane and again on the opposite corner of the rectangle. The sketch should
look similar to Figure 8.

Figure 8: Initial duct cross-section sketch.

The sketch will automatically attempt to lock onto grid lines.
8. Right click on one of the horizontal lines and select the Apply Length Dimension under the

Dimensions section. The Dimension Window will open. If necessary, change the length of the
line to 0.2 [m] and click OK.

9. Right click on one of the vertical lines and select the Apply Length Dimension under the Dimensions
section. The Dimension Window will open. If necessary, change the length of the line to 0.3 [m]
and click OK. The completed sketch with dimensions is shown in the following Figure 9.
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Figure 9: Completed duct cross-section sketch.

10. Once you have defined the dimensions of your sketch, click on the OK button in the Explorer Pane
to create the sketch.

11. Right click on Sketch 1 and select Rename. Rename the sketch to Duct Cross-Section Sketch.
Alternatively, you can use the F2 hotkey to rename a node in the Explorer Pane.

12. Right click on Duct Cross-Section Sketch and select the Extrude option. This process and the
renaming process is shown in Figure 10.

Figure 10: Renaming and extrusion features in tree.

13. The Extrusion Window will open in the Explorer Pane. Change the distance to 2.0 [m] and click
OK. This can be seen in Figure 11.
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Figure 11: Extrusion of cross-section sketch in explorer window.

14. Right click on the Extrude 1 feature and select Rename. Rename the extrusion to Duct.
Open the Duct → Body Groups node. Right click on Body 1, select Rename, and rename the
feature to Duct Body.

15. In the Display Window, right-click each individual face of the model and rename it using the
following naming convention shown in Table 1. The following Figure 12 depicts renaming the
negative x-face to ”Inlet”:

Table 1: Naming Conventions for Duct Faces
Face: Plane: Name:
Negative x-Face x = 0 Inlet
Positive x-Face x = Lx Outlet
Negative y-Face y = 0 Symmetry Plane
Positive y-Face y = Ly Top Wall
Negative z-Face z = 0 Left Wall
Positive z-Face z = Lz Right Wall

University of Manitoba R1.3 2022-10-11



STAR-CCM+ Introduction Tutorial Part 1: A Simple Duct Mesh Page 10 of 19

Figure 12: Renaming for faces in the 3D-CAD modeler.

16. Click on the Close 3D-CAD button in the Explorer Pane. The model is now complete.

2.3 Creating a Part from a 3D-CAD Model
Now that the 3D-CAD model is complete, it must be converted to a geometry part for meshing and
analysis. This section summarizes the process of creating a part from a 3D-CAD Model in STAR-CCM+.
Alternatively, one could have created a 3D-CAD model in another software, imported it, and then it
may be converted into a part using the same process.

1. Click on Geometry → 3D-CAD Models and rename 3D-CAD Model 1 to Duct.
2. To create a part from the 3D-CAD Model in STAR-CCM+, right click on Geometry → 3D-CAD

Models → Duct. Select the New Geometry Part option,as shown in Figure 13.

Figure 13: Process of creating a part from a 3D-CAD model.

3. The Part Creation Options dialog box will open. For this tutorial, the default settings will be
what is used, so click OK. This process is shown in the following Figure 14:
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Figure 14: Part creation options dialog box.

4. To view your geometry in the Display Window, right click on Scenes and select New Scene → Geometry.
This is shown in the following Figure 15.

University of Manitoba R1.3 2022-10-11



STAR-CCM+ Introduction Tutorial Part 1: A Simple Duct Mesh Page 12 of 19

Figure 15: Extrusion of cross-section sketch in explorer window.

5. The duct should now be available in the Display Window and should look similar to Figure 16.

Figure 16: View of duct body in geometry scene.

6. Prior to setting up the mesh for the geometry, the geometry part must be converted into regions.
Regions are various surfaces on the part where you can set boundary conditions and define the
behaviour of the surfaces of a part. To do this, right click on Geometry → Parts → Duct Body and
select Assign Parts to Regions. . .
This process is shown in Figure 17.
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Figure 17: Process of assigning parts to regions.

7. The Assign Parts to Regions dialog will open. Select the Duct Body as the part to assign to
regions. Change the pull down menus to read the following:

• Create a Region for Each Part
• Create a Boundary for Each Part Surface
• Create One Feature Curve for All Part Surfaces

The selected options on the pull down menus should look like Figure 18. Once this is completed
click Apply and Close.

Figure 18: Assign Parts to Regions menu selections.

8. To ensure you have correctly assigned parts to regions correctly, you can expand the Regions → Duct
Body → Boundaries node. Each face named when creating the 3D-CAD model, should have been
converted into a separate boundary as seen in Figure 19:
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Figure 19: Boundaries created when assigning parts to regions.

9. The part geometry has been created and set up for meshing. Ensure the simulation is saved prior
to starting the meshing section by clicking File → Save, and title the simulation duct.sim.

3 Meshing
This section outlines the process of creating a mesh for a given part. The purpose of creating a mesh
is to divide the geometry into volumes (or areas for a 2D mesh) used in the discretisation process.
This section will also summarize the procedure of exporting a mesh for use in later simulations. The
saved file can be used in the subsequent tutorial: STAR-CCM+ Introduction Tutorial Part 2: Laminar
Flow in a Rectangular Duct. The meshing process used is just one type of mesh generation available in
STAR-CCM+.

3.1 Creating a Directed Mesh
The type of mesh that will be used in this analysis will be a directed mesh. The key features of a
directed mesh are the source surface and the target surface. A patch mesh is created on the source
surface and is extended through the use of a volume distribution to the target surface.

University of Manitoba R1.3 2022-10-11



STAR-CCM+ Introduction Tutorial Part 1: A Simple Duct Mesh Page 15 of 19

1. To begin creating the mesh for the simulation, right click on Geometry → Operations and select
New → Mesh → Directed Mesh, as shown in Figure 20.

Figure 20: Process of selecting the directed mesh option.

2. The Create Directed Mesh Operations menu will open on screen. Click on Duct Body to select the
body you wish to create the mesh for and click OK. A new Directed Mesh node will appear under
Operations in the Explorer Pane.

3. Right click on Geometry → Operations → Directed Mesh and select Edit. . .
This process is shown in Figure 21. The Directed Mesh window will open in the Explorer Pane.

Figure 21: Process of opening the mesh editor.

4. Select the Source Surfaces node and in the Properties Window, open the Custom Editor and select
the Inlet as the source surface. The button to open the Custom Editor is shown in Figure 22.

University of Manitoba R1.3 2022-10-11



STAR-CCM+ Introduction Tutorial Part 1: A Simple Duct Mesh Page 16 of 19

Figure 22: Button to open the Custom Editor.

5. Select the Target Surfaces node and in the Properties Window, open the Custom Editor and select
the Outlet as the target surface.
The Directed Mesh will begin on the Source Surface and travel to the Target Surface, which is why
these surfaces must be defined prior to creating the mesh.

6. Right click on the Source Meshes node and select New Source Mesh → Patch Mesh.
The Part Collection For This Source Mesh window will open in screen. Select the Duct Body as the
part you wish to create the source mesh for and click OK.

7. The Patch Mesh Editor will open, which is where the mesh is created on the source surface. Click
on the Auto-Populate Feature Edges with Patch Curves icon under the Create/Edit Patch Entities
section. This icon is shown in Figure 23. Once this is done correctly, the edges of the source
surface will change colour from yellow to green. Your patch topology should begin by looking like
Figure 24a and end looking like Figure 24b.

Figure 23: Auto-Populate Feature Edges with Patch Curves icon.

(a) Initial patch topology. (b) Final patch topology.

Figure 24: Patch topology on source surface.

The Auto-Populate Feature Edges with Patch Curves feature will automatically create one large
patch mesh around the perimeter of the source surface. This is the desired patch mesh for the
simulation, so the patch mesh creation is complete.
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8. At the top of the Explorer Pane, change to mode from Patch Topology to Patch Mesh. This is
where the number of nodes in each direction on the source surface are specified. Click on one of
the horizontal edges. The Mesh Properties section in the Explorer Pane will become available once
done correctly. Change the number of divisions to 15 and click Apply, as shown in Figure 25.

Figure 25: Process of specifying the horizontal mesh divisions.

9. Click on one of the vertical edges. The Mesh Properties section in the Explorer Pane will become
available once done correctly. Change the number of divisions to 10 and click Apply, as shown in
Figure 26.

Figure 26: Process of specifying the vertical mesh divisions.

10. Once both actions are completed correctly, the mesh on the source surface should appear in the
Display Window. When the mesh looks similar to the mesh in Figure 27, click on Close to close
the surface mesh.

Figure 27: Patch mesh of source surface.

11. Right click on Mesh Distributions and select New Volume Distribution, as shown in Figure 28. The
Parts for Creating a New Mesh Distribution menu will open on screen. Select the Duct Body as the
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body to create the volume mesh for and click OK. A new Volume Distribution node will be added
under Mesh Distributions.

Figure 28: Creating the volume distribution node.

The purpose of the volume distribution is to set the number of divisions of the patch mesh from
the source surface through the body to the target surface.

12. Select Mesh Distributions → Volume Distribution → Default Controls → Number of Layers and in
the Properties Window, change the Number of Layers to 40 and hit Enter. This process is shown
in Figure 29.

Figure 29: Process defining the volume distribution.
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13. The directed mesh is now complete, so click on Close Directed Mesh. This will cause STAR-CCM+
to return to the Geometry Scene.

14. To update the directed mesh, right click on Geometry → Operations → Directed Mesh and select
Execute. The small caution icon beside Directed Mesh node will vanish once completed .

15. To view the directed mesh, right click on Scenes and select New Scene → Mesh
A new scene should open in the Graphics Window which shows the Duct Body and the directed
mesh, similar to Figure 30.

Figure 30: View of duct body in mesh scene.

16. Save the simulation by clicking File → Save.

3.2 Exporting the Mesh File
It is suggested to simply save the mesh created above in a .sim file rather than exporting the mesh as
a .ccm file.
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