C File System File Functions

EXPERIMENT 1.2




Propose of the experiment

= Continue from previous experiment to be
familiar with CCS environment

= Write a C language file input / output (CIO)
program to read in a data file and write out a
data file

= Understand how binary data will be handled
by CCS differently than the ASCII text data

= The ClIO feature introduced in this experiment
will be used in future experiments




Start CCS

(Example: Code Composer Studio Version 5)

| O Code Composer™ Studio v5

.
> |




Create workspace
(Example: C:\User\DSP_Experiment\Chl\Expl.2)

+'+ Workspace Launcher

Select a workspace

Code Composer Studio stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

Lol o=l Users\DSP_Experiments\Ch1\Expl.2 Browse...

Use this as the default and do not ask again

| | Cancel




| Go to CCS

"+ CCS Edit - Code Composer Studio
File Edit View MNavigate Search Project Tools Run Scripts Window Help

<+ Welcome

Start using
Welcome to o

O Click to close

and go to the

CCs

You can bring up this page at any time by selecting Welcome from the help menu. workbench
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Create a new project

(File -> New -> CCS Project)
[+ ccs ot cone camposer Swaio S

File | Edit View Source Refactor Navigate Search Project Tools Run Scripts Window Help
Alt+Shift+N ¥l  CCS Project v v

New
I Project.

Open File... =g
Source File

Header File

Class

File from Template

Folder

Target Configuration File

DSP/BIOS v5.x Configuration File

RTSC Configuration File

Ctrl+Shift+5

Y COther... Ctrl+N
Refresh

Convert Line Delimiters To

Print...

Switch Workspace
Restart

Import...
Export...

Properties

Exit
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I | B CCS Edit
o= Outline &2 ¥ =08
An outline is not available.




+'+ CCS Edit - Code Comf »+ New CCS Project

File Edit View Sourd ces Projec’( —5

2 Create a new CCS Project. k / I[j CCS Edit
Hg C/C++ Projects &2 e 2 v =5
; e is not available.

4'| Project name: filelO

v| Use default location

Cancel

g~ Licensed




Select C5500 as the new project

'+ New CCS Project

Select a type of project

Select the platform and configurations you wish to deploy on

| SelectAll |

‘ Deselect All ‘

Cancel




Go to next
(We do not need any additional settings)

'+ New CCS Project

Additional Project Settings

Define the inter-project dependencies, if any.

= Projects | C/C++ Indexer

Referenced C/C++ Projects

Cancel




Set up the project

(Executable output, Device C5505, Library rts55x.Ll1ib)

«» New CCS Project

Project Settings

Select the project settings.

Output ty'p 1@ M |

Project settings

Device Variant:

Device Endianness:

Code Generation tools: |TI v4.3.8
Qutput Format:

Linker Command File:
e ..

Runtime Support Libra @




Project: filelO

"+ CCS Edit - Code Composer Studi

File Edit View Source Refactor Navigate Search Project Tools Rum Scripts Window Help

| & % @ - @ v R~ Hv 4 s (& Ccs Edit

- -

0@ C/C++ Projects 3 = B || 8 Outline 2 ¥ =08

An outline is not available.
5

- [i= filelO
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Copy files to workspace

= Copy the following files cam with the book to workspace (folder filelO)
[nk.cmd
filelO.c
tistdtypes.h
C55DSPUSBStickAudioTest.pcm

= (reate afolder under Exp1.2 and name the folder “output”

=

:" \' _M| « DSP_Experiments » Chl » Expl2 » filelO »

Organize ~ Include in library Share with - Burn =2
4 D5SP_Experiments - Name
. Chl
Expll & C55D5PUSBStickAudioTest.pcm
4 | Bxpll filelO.c

metadata < Ink.cmnd

il=® tistdtypes.h




|  CCS project

(The fileIO.c and 1lnk.cmd are included in the project)

&% CCS Edit - Code Composer Studio (| T

File Edit View Source Refactor Navigate Search Project Tools Run Scripts Window Help
- @~ /R~ B~y F~ & | B CCS Edit

0@ C/C++ Projects = O || 5= Outline 2 =08
An outline is not available.

s

4 = filelO

1| filelO.c
- 0l tistdtypes.h
C55DSPUSBStickAudioTest.pcm
& Ink.cmd
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Setup build environment

= Right click on filelO then select Property
= Select and expand C/C++ Build option
» Select Settings, then Runtime Options

= Set type size to 16 and memory model to
large




Set target configuration

» Right click on Project->New->Target
Configuration File

= Create a target configuration file name,
filelO.ccxml

s Select Texas Instruments XDS1oov2 USB
Emulator

= Check the box for USBSTK5505
= Save the configuration




Launch target

* FromTarget Configuration window
= Open Project and right click on filelO.ccxml
= Select Launch target configuration

* |n Debug window, right click on Texas
Instruments XDS1o0ov2 USB
Emulator_o/C55xx

= Select Connect Target to launch the target

= You shall see target reset and configured
automatically




Build the project

(Project->Build ALL)

<+ CCS Edit - fileIO/fillO.ccxml - Code Composer Studit

File Edit View MNavigate Search Tools Run Scripts Window Help

i ! Open Project Fi * CCS Debug E >
A A L= 4 Close Project
0@ C/C++ Projects 52 > Build All cul+B | =0|go. |EBT. |®Di.xz| =0
Build Configurations 4 = ||No debug context =
2 filelO Build Project
#¥ Binaries Build Working Set ’
@l Includes Clean... out the target.
= Debug Build Automatically Erulator
L fileIO.c
ln] tistdtypes.h
C55DSPUSBStickAudioTest.g
% fill0.coxml [Active/Default] Add Files...
# Ink.emd Link Files...

| Enter location here  ~

[Emulator

% Import Existing CCS/CCE Eclipse Project
% Import Legacy CCSv3.3 Project

128335
Properties
M Experimenter's Kit - Piccolo F28027
Experimenter's Kit - Piccolo F28035
0SK5912
< 111

Basic| Advanced | Source

E Console 2 = O || Problems &2
C-Build [filelO] 0 items
4 ¢ [B) B &8 Gl Description

el > [~

e e & e o=

ke\gmake -k all
gmake: Nothing to be
done for “all'.

Licensed




Load program filelO.out

* From CCS Run->Load->Load Program

= Blows and select the executable file
fileiO.out from
C:\Users\DSP_Experiments\Chi\Expai.2\filel
O\filelO.out

» Click Open and then OK to load the program



Once the program is loaded

(Program counter is at entry point of function main() )

wsx CCS Debug - filelO/filelO.c - Code Compaoser Studi

File Edit View Source Refactor Navigate Search Project
i | 1o " év};() ‘3'&'
%% Debug 2 = O ||x=Variables 2 |4 Expressions
O 0] @ 7|3 23D ® @~ &|en~

a e fillO.coxml [Code Composer Studio - Device Debugging]
4 ® Texas Instruments XDS100v2 USB Emulator_0/C55xx (Susg

= main() at filelO.c:24 0x000234B1
_args_main() at args_main.c:25 0x000243F0 (_args_mai

Tools Run Scripts Window Help
3&5: - E V-.'" - - -

| i=
Value Location
0x5192B...
OxF18A..

2393348...

Name
» fpl
» fp2
6= |

Type
struct un...

struct un...
unsigne...

Il

| fillO.coxml g filelO.c i | [g tistdtypes.h =8

3wvoid main()

FILE *fpl,*fp2;
Uint32 i;

printf ("Exp. 1.2 ——— file I0\n"):;

fpl =
fp2z =

fopen (™. .\\C55DSPUSBStickhAudioTest.pcm", "rb");
fopen (".\\..\\..\\output\\C55DSPUSBStickRudioTest.wav", "|_

if
{

(fpl == NULL) ' check if the input file exists
printf ("Failed to open input file 'C55DSPUSBStickRudioTest.
exit (0):;

}

fseek (fp2,
i=0;
while (fread(ch,

44, 0); ' advance output file point

sizeof (Uint8),
Ll

SIZE, fpl) == S5IZE)

Licensed

Writable Sma..ert

L= 2 -

= B | % Breakpoints i3
5 | € =

0x00001...
0x00001...
0x00001...

E=ETE

& [*5 CCS Debug

[
=0

-

R & %

o%'|

=
+ = S

Ide.. Na..

Brea..

Acti...
Rem...

Cou...
0@

Con...

% Target Co... |E Console = |~ O
C-Build [filelO]
& 4 (B B & Gl

gl = il

*%x%% Build of
configuration Debug

for project filelIO
L &

C:\ti\cesvSh\utils\gmak
e\gmake -k all

gmake: Nothing to be
done for “all'.




Use Resume Run the program

(CCS console displays experiment messages)

+"+ (CS Debug - fileIO/filelO.c - Code Composer Studit E

File Edit View Source Refactor Navigate Search Project Tools Run Scripts Window Help

4~ gl Era8- PR &~ By & HeFvoeya~ ¢ (% CCS Debug |1
%5 Debug 2 = 0| /&= Varia.. 5 | Expr.. | = O| @@ Help | B Console =8
O (] @ &7 | 32 3 B | i PR AL £ 3| e =
«# fillO.ccxml [Code Composer Studio - Device Debugging] Name Type
o Texas Instruments XDS100v2 USB Emulator_0/C55xx (Suspended) . completed
= abort() at exit.c60 0x000245A2 (abort has only skeletal debug - 1.2 — file IO

=

4 il I 4 LI}

2| fillO.ccxml l<| tistdtypes.h <] filelO.c &2 | [c] abort() at /sim/sds12/scratch/a0322878 _rt...

23 void main ()

24 4

25 FILE *fpl, *fp2;
Uint32 i;

1 oy

printf("Exp. 1.2 ——— file I0\n");

W B B [ [ [

fpl = fopen("..\\C55D5PUSBStickhudioTest.pcm", "rb");
fp2 = fopen (".\\..\\..\\output\\C55DSPUSBStickiudioTest.

if (fpl == NULL) // check if the !
i
printf ("Failed to open input file 'C55DSPUSBStickhudioTe:
exit (0);

}

fseek (fp2, 44, 0);
i=1;
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Verity the program result

= After running the experiment, your program
shall create a WAV file named as
"C55DSPUSBStickAudioTest.wav” in the

output folder that you have created

= Play this WAV file using a player such as
Windows Media Player. You shall hear the

male voice saying: "Cgsg DSP USB Stick Audio
Test”.




New experiment assignments

=  Write a C program that will
Read the input data file, C;5sDSPUSBStickAudioTest.pcm, as Exp1.2

Open a file to write the data in ASCll integer, the name of the output file can be
"C55DSPUSBStickAudioTest.xls”

hint: use fprintf() function to replace fwrite()

Convert every two -byte input data values into an integer (16-bit) number as:
o = ch[j]]| (ch[j+1]<<8); /[ wherej=0, 2, ....
and write input data in ASCll integer to output file

Build and run the program to generate your output file

using Microsoft Excel to open the output file, select the data column to plot the
data to view the waveform of "C55DSPUSBStickAudioTest”, see next page

=  Write a C program that will

Read the input file "C55DSPUSBStickAudioTest.xls” created in above experiment
and generated a WAV file output
Play the WAV file on a computer and listen to the audio.

Qa: Does it sound the same as the WAV file output obtained from the experiment given
in section 1.5.2 (Exp1.2)?




The new experiment result

(The waveform of the audio C55 DSP USB Stick Audio Test)

|z“ [ M C55DSPUSBStickAudioTestxls - Microsoft Excel

20
28
36
39
55
57
56
66
62 T T ' N W Seriesl
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48
M 4 » M| C55DSPUSBStickAudioTest <]
Ready | Average: 0.571693157 Count: 20696 Sum: 16977 | EH|[O 100% (—)




Programming quick review 1

This experiment used a few more C file 10 functions, such as fopen(), fread(),
fwrite (), and fclose( ). These functions are defined in the header file stdio.h.

The fopen() and fclose() are used to open and close the files used in the
experiment. The fread() and fwrite() are used to read data and write data from
and to the input and output devices.

The fopen() function has two arguments, the first argument is a character string

for the name of the file and the second argument is also a character string telling

the function how to use the file opened. The second argument “rb” and “wb”

glsed in the filelO experiment are for reading binary data in and writing binary
ata out.

For any file opened, it must be properly closed after the operation. This can be
done by the fclose() function.

The fread() and fwrite() functions have 4 arguments. The fread reads from
stream (4" argument) into the array (2t argument), the number of data (3™
argument) with the size of (2" argument). The fwrite writes data in the array (25
argument) to the stream (4" argument), the number of data (3™ argument) with
the size of (2"d argument).

The fseek() and rewind( ) functions are used to set the starting point of the files
for writing the output data. These functions help manage the file access.



Programming quick review 2

= (Clanguage has many different data types.

= Toimprove portability of the programs written for one type of computer
devices to another, we use a unique type define header file, tistdtypes.h,
to specify the data type to avoid any ambiguity.

= The following data types are used in this experiment
Uint8 (unsigned 8-bit integer data, unsigned char)
Uint32 (unsigned 32-bit integer data, unsigned long )
FILE * (file pointer)

= Special notice: fread() and fwrite() functions in CCS these functions will
only read or write byte size (8-bit) binary data during memory access.
When the fread( ) function reads a 16-bit data into a data memory
location, for example ox1234, it reads ox34 first then ox12, and place
them into memory ch[o]=0x34 and ch[1]=0x12. When fwrite( ) function
writes data ox1234. It only writes 0x34 but not write ox12. So it is
important to convert each 16-bit data into two 8-bit data and read or
write two bytes for experiment.
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